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Clarity Report Designer 

Introduction 

MYOB EXO Clarity 

Clarity is the MYOB EXO Business report writer especially written for use with MYOB EXO Business. The 
Report Designer is the application you will use to build MYOB EXO Business reports.  

This manual assumes a basic understanding of databases, and a general understanding of the operation 
and table structure of MYOB EXO Business. 

Main Clarity Report Types 
There are mainly three kinds of Clarity report types in MYOB EXO Clarity depending upon the functionality 
required of them. 

Clarity reports (.CLR)  

Most commonly used report type. Each CLR can have its own set of runtime parameters stored as a .CLS file 
and can be run from a menu, the command line, custom buttons, and so on.  

Clarity Business Forms (.CLF) 

Specific Clarity Forms are identified with specific functions within MYOB EXO Clarity. These are essential 
business forms that are part of the usual business workflow. In contrast Clarity Reports (CLRs) can be placed 
on the MYOB EXO Business menu or run via the command line, and can in fact be given any name and there 
can be any number of them.  

A few notable exceptions exist however. Examples include where you are using a variety of invoice forms 
and they are specified by on the Debtor Account Details > Details 2 tab - Invoice file number – e.g. 
Invoice1.CLF, Invoice2.CLF - or if you have set up you system to prompt you to select from a list of formats 
when you save an invoice or sales order. 

Another characteristic of a CLF file is that it is automatically passed a single key value such as a transaction 
record number or an account number to the data pipeline named “Master” in your CLF definition. For 
example, MYOB EXO Business will pass the DR_Trans Seqno to the file named Invoice.CLF. Therefore the 
DR_Trans.Seqno field must be in the data pipeline named “Master” on the data tab in Clarity. 

Clarity Merge Files (.CLM) 

CLM files are basically used to produce clarity merge files. 
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Report Designer Tabs 

Clarity contains four main tabs: Data (see page 4), Design (see page 2), Preview (see page 3) and Detail (see 
page 4), with Calc (see page 50) reserved for more advanced development. 

 

Design Tab 

When first loaded, the MYOB EXO Clarity Report Designer always defaults to the Design tab workspace, 
because this is where you will spend the majority of your report-building time. The Design workspace is 
divided into two areas: the workbench and the canvas. The workbench (shown below) comprises toolbars 
(see page 14), component palettes, rulers, and other tools that can be used to manipulate the canvas.  

 
The canvas is the area that contains the report layout. This is where we place the bands (or sections) and 
components that will ultimately control the content of each page of the report. 

• Title band - Generally contains the title of the report and prints on the first page only. 

• Header band - The header band prints at the top of each page. 

• Detail Band - The detail band prints once for every row of data. 

• Footer Band - The footer band prints its on the bottom of each page. 

• Summary - The summary band prints once at the end of a report. The band is typically used to 
summarize data. 

• Page Style - The page style band allows you to set components (for example, images or 
watermarks) as a background for each page of your report. This is typically only used in advanced 
reports. 
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All bands except the Detail band can be either shown or hidden by selecting or de-selecting the appropriate 
option under the “Report” menu. 

Note: If the title and summary do not appear on the canvas, they need to be activated from the 
Report Menu (see page 27). 

Preview Tab 

The Preview tab plays an integral role in the report-creation process as it allows you to preview the report 
as it will look when printed. This tab is frequently accessed so that one can see how the report is shaping 
up. Many changes and corrections are based on what is seen in this preview.  

Tools in this tab allow you to view each page of the report or zoom in to get a better look at a specific page. 
You can browse on screen or you can print the report from the preview tab. 

 
Note: You cannot edit in the preview window. 
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Data Tab 

The Data tab is the key to successful report creation as it allows you to select and manipulate the source 
data needed for a given report. These tasks are accomplished via two visual tools:  

• the Query Wizard  

• the Query Designer 

These tools greatly simplify the often-difficult task of data selection by giving us the ability to select data 
without requiring too much in-depth knowledge of the underlying MYOB EXO Business database structures. 
Either of them can be used to achieve the same result, the difference being that the Wizard leads you step 
by step through the processes whereas the designer is a quicker way for the more advanced user to select 
the data. 

The options on the main drop down menus at the top of the screen change when you move to this tab. By 
selecting one or more tables and joining these tables where needed, “Data pipelines” can be constructed 
containing only the data required in your report. This gives the benefit of speed, as the subset of data is 
smaller and any heavy processing is performed on the server.  

The screen capture below shows the data tab with a number of data pipelines. The coloured lines between 
the data pipelines represent the links between them. They link specific fields to each other, and are often 
slower than the table joins within the data pipelines, but there are extra benefits with these, which will be 
explained later.  
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Detail Tab 

This tab is the equivalent of the powerful Report to Grid option in previous MYOB EXO Business versions. It 
displays the data obtained from the data source that has been selected for the primary detail. The specific 
MYOB EXO Business component procedure can be selected when drilling on the line in the details band of 
the report.  

All the usual options of Account Maintenance, Stock Item Maintenance, General Ledger Account, Sales & 
Purchase Order, and Invoice are available. User profile security policies will still apply when these functions 
are called. 

The Click To drop down box should be changed to select what you would like to drill down to. For example, 
in a Debtors Invoice Listing Report it is possible to drill down to either the Debtors Account or the Debtors 
Invoice. 

 

Data Tab 

Data Tab Overview 

As discussed in the Data Tab introduction (see page 4), the Data tab is where the database tables and fields 
are selected. This section will explain the process of such selection, as this is an important part of the report 
writing process. If the wrong or no data is extracted, there is no chance of the final report recording the 
results correctly.   

In this section the use of the report Query is discussed, as it is most likely the one you will choose to use.  
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To create a new data pipeline, from the Clarity Report Designer click on the Data tab so that you see a grey 
screen with only the menu option of File available. Select File > New, and double click on the Query 
Designer icon. 

 

Creating a Data Source 

This can also be referred to as a Data Pipeline. 
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The illustration above depicts the data source for a very simple report. 

One of the more difficult tasks of creating a report is determining which tables and fields you need to select 
to obtain the required information. 

1. Start by making a list of all the fields you need to display on your report. A suggested method is 
creating a rough sketch of what you would like your report to look like when it prints out 
(displaying a line or two of example data). You can then make a list of the fields required to show 
this information. 

2. If any of the required fields are calculated fields, ascertain from which field(s) they will be 
calculated, and add those source fields to the list of required fields. 

3. After ascertaining which fields are required, make a list of all of the distinct tables that the fields 
come from.   

4. Establish how these tables are linked in the database, i.e., which fields they are linked on. 

You now have all of the information required to create a data source and it is just a matter of selecting the 
distinct tables in your new data source identified in step 3 above, and joining them with the links 
established in step 4. The individual fields required, as identified in steps 1 and 2, will then be able to be 
selected, to be used in your report directly or to within calculations. 

Query Designer 

Tables Tab 
Select Data tab> File> New, then double click on the Query Designer icon. The Query Designer window 
splits in two, with the upper window displaying all of the MYOB EXO Business database tables available for 
use in report writing.  

 
The lower window is at present blank, and this is where your selection will be stored.  
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To select items on any of the tabs, double click on a line in the top pane (in this case a table), and the line 
will copy into the bottom pane. For example, double click on DR_TRANS in the top pane to add it to the 
bottom pane.  If you then decide that you have made a mistake and want to remove it from your selection, 
simply double click on it in the lower pane, and it will disappear.  

Note: If you click the OK button at this stage after only selecting a table, you will be confronted with 
an error message. This is because no data fields have been selected, and selecting a table on its own 
without fields is of no use. 

If you select a second or subsequent table, the Join Table screen appears: 

 
In this dialog box you can create a table join. A table join links two tables based on a common field. To add 
a join condition, you need to select four options:   

1. First, you must select the type of join: Inner, Left Outer, Right Outer, or Full Outer. 

2. Second, choose the table to which you want to join from a list of existing tables in the data pipeline. 

3. Third, highlight the new table’s join field (on the left). 

4. Lastly, select the existing table’s join field (on the right), and click Add when you are happy with the 
selection. 

In the example above we are “inner” joining the DR_TRANS table (new) to the DR_ACCS table (existing) via 
the Accno field.   

All unnecessary joins listed in the Joined Fields box must be removed, or you may not get the results you 
intended (Clarity adds joins between fields of different tables with the same name automatically). 
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Fields Tab 
Once you have selected the tables required, click on the Fields tab. 

 
To select items, double click on a line (in this case a field), and the line will copy from where it is, to the 
other window; when you choose a field it disappears from the top window and only appears in the bottom 
window. This means that although you can choose the same table more than once, you cannot choose a 
field more than once from the same instance of that table. 

To remove from the bottom window - simply double click it again. 

Note: In the bottom right quadrant of the screen there is a small check box with the caption All 
fields. As the name suggests, if ticked, all of the fields in the top window will now be selected and will 
appear in the bottom window. 

Keep in mind that as you select more fields this proportionally increases the amount of data that the 
computer will have to sift through when running a report. Consequentially the longer it will take to run, so 
it's good practice to only use the ones you need. Should you find later on that you are in need more fields 
you can return to this window and select more. 

Field Selection Procedures 

To move an individual field from the top window to the bottom window, double-click a line from the top 
window to copy it to the bottom window. This method is fine if you only need to select a few fields, there 
are quicker methods for adding fields: 

• To find field names more easily, they may be sorted by field alias. To do this, click the Field Alias 
title bar. Click in the list of fields and type the first letter of the field you're searching for. The list 
will scroll to that location. 
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• Instead of selecting fields individually by double clicking, multiple fields can be selected by using 
the default Windows selection method of holding down the CTRL or SHIFT key when selecting with 
the mouse. Alternatively drag a box around the fields that need selecting - in this example start at 
click and hold the mouse button down then drag the selection to point. 

• Release the mouse and click and hold down the mouse button when the cursor is on the selection. 
Now drag the selected group to the bottom window. 

• There are other options from the right click menu, both from the sort fields window and the 
available fields window. These may vary according to the tab selected. The best method is to 
experiment, right clicking will do nothing until a left click action follows this. To get out of the right 
click menu without affecting your selection, press the ESC key. 

Calcs Tab 
The Calcs tab is where simple mathematical calculations are performed.  

 
To record a calculation, choose any field from the top pane and double click on it to bring it down to the 
bottom pane. Select a function from the drop down list depending on what calculation you wish to apply to 
the field (e.g. Sum(), Count(), etc.), or select the expression option for a more complex calculation and 
enter your formula. An alias may then be entered for the resulting field.   

For example, if you only had the amount and the exchange rate fields available, but you need to display the 
foreign currency of an amount of money, you would need to perform a calculation. To calculate the foreign 
currency amount you would enter the expression (amount/exchrate), and then rename the alias to 
FCAmount.  
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To select items, double click on a line (in this case a field), and the line will copy from where it is, to the 
other window; when you choose a field it disappears from the top window and only appears in the bottom 
window. This means that although you can choose the same table more than once, you cannot choose a 
field more than once from the same instance of that table. 

To remove from the bottom window, double click it again. 

Group Tab 
Unless you know what you are doing, you may wish to ignore this tab as there are easier methods of 
grouping in the report itself (see page 38). If you add an aggregate function like Sum() in the Calcs tab, 
Clarity will automatically add non-aggregated fields to the list of fields to group by. This is normal behaviour 
and you cannot remove these. 

Search Tab 
The Search tab is where we enter selection criteria in order to narrow down the selection of data to be as 
small as possible. For example, this is where a date range would be recorded, or the records restricted to 
those where balances are > $0.00.  

To select items, double click on a line (in this case a field), and the line will copy from where it is, to the 
other window; when you choose a field it disappears from the top window and only appears in the bottom 
window. This means that although you can choose the same table more than once, you cannot choose a 
field more than once from the same instance of that table. 

To remove from the bottom window - simply double click it again. 

To begin building the search criteria, right click on the field name and include the search condition. Add an 
operator from the drop-down list and choose an appropriate value to enter into the value field.  

 



MYOB EXO Clarity 

12 

Note: As Clarity does not have the facility to enter a sample size, use the search screen to make your 
sample size as small as you need it to be so that your report runs quickly whilst you are building and 
testing. However don’t forget to remove the unwanted search criteria before installing your report in 
a live situation. 

Sort Tab 
This tab defines the sort order that the data will be listed in the report.  

If you are grouping in Clarity by fields other than using the data pipeline Group tab (i.e. using the Report > 
Groups menu option, which is the recommended option at this stage), it is essential that the fields that you 
order by are the same ones that you group by and in the same order, or your report will not make sense. 
 Once these fields have been added in the correct order, any further fields can be added to sort records 
within the group. For example, in order to correctly group records in a report by Debtor account you must 
have the records sorted by Debtor account.  You could then add a Sort field for the invoice number to sort 
by invoice number within the Debtor account. 

To select items, double click on a line (in this case a field), and the line will copy from where it is, to the 
other window; when you choose a field it disappears from the top window and only appears in the bottom 
window. This means that although you can choose the same table more than once, you cannot choose a 
field more than once from the same instance of that table. 

To remove from the bottom window, double-click it again. 

 
Highlight a sort item and click the check box to make it a descending sort. 
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SQL Tab 
By default, the only editable part of the SQL tab is the Name field, which is the name you give the new data 
source/data pipeline. The rest in the greyed out area shows the commands that you have performed on the 
tables and fields turned into SQL. Thus if you are familiar with SQL code, this tab provides a useful check to 
see that you have made the selections you intended. 

 
In the above example, the data source has been renamed to "Master". This is because MYOB EXO 
Business looks for a data source named Master to apply search criteria to when passing parameters such 
as transaction sequence numbers through to reports. 

Editing SQL 

To edit the SQL statement manually, right-click on the main area of the tab and select Edit SQL. You can 
now enter any SQL statement you want here; for example, you can enter a query to take data from a 
view, function or stored procedure in this mode. 

Note: Once you choose edit the SQL manually, this cannot be undone; the query can only be edited 
manually from now on. All of the tabs on the Query Designer window are hidden. 
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Workbench Toolbars 

Workbench Toolbars Overview 

This section introduces you to the various toolbars and their functions. 

 
You can view a list of all toolbars in MYOB EXO Clarity and select those that you want to always show, by 
selecting the View > Toolbars option from the Report Designer main menu, or by right-clicking anywhere 
on the workbench toolbar area. You should probably select all the toolbars and become familiar with what 
each tool does.  

Available Toolbars 
The workbench is controlled by a series of toolbars to accomplish specific tasks. These are described below. 
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Ref Name Description 

 

Standard Components 
(see page 15) 

Used for headings, labels, and company logos etc. that are 
required to help identify the report or form.  

 

Data Components (see 
page 17) 

The set of tools that are used to extract data from the 
database. Data-aware components have the ability to read 
the value of a field from a database table, and then display 
that value in the report. 

 

Advanced Components 
(see page 22) 

To tackle and control complex reporting layouts. 

 

Edit (see page 26) The Edit toolbar is unique in that it changes based on the 
selected component. It consists of two white boxes with 
drop down capabilities. 

 

Format (see page 25) Used to set the font and colours of text-based components. 
It's also used to control the layering of components. 

 

Size (see page 19) You can use the Size toolbar to set all of the components 
within a selection to a uniform height or width. 

 

Align or Space (see page 
21) 

Is useful when components need to be positioned 
uniformly. For example, it can align several components so 
that the tops are all even. 

 

Nudge (see page 19) Is useful when you want to move a component or selection 
of components with extreme precision. 

 

Standard (see page 24) For functions such as opening, saving, and printing reports, 
as well as cutting and pasting selections. 

 

Draw (see page 20) Is used to set the colour and style used by shape, line, and 
region components. 

 

Report Tree (see page 23) Used to view the components within each band of the 
report in a vertical linear format. 

 

Data Tree (see page 24) Can be used to create data-aware components within a band. 

 

Standard Component Palette 

 
The Standard Component palette and the one described hereafter, the Data Component palette would 
appear at a glance to contain the same elements. Although the similar icons do similar things, their overall 
purpose is very different. The Standard Component palette is used for headings, labels, and company logos 
etc. that are required to help identify the report or form. The Data Component palette is the set of tools 
that are used to actually extract data from the database. 

The icons on the Standard Component palette represent components that are frequently used to build 
reports. To use a component, click on an icon and then click in a report band. 
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Icon Description 

 

Selection tool: Selects one or more components within the layout. Also clears any 
selection (by clicking in the white space of a band). 

 

Label: Displays text. To set the caption of a label, highlight ‘Labelx’ which appears in the 
white window below this toolbar, and over type it with the text you require. You need to 
have selected the label first before you do this. 

 

Memo: Prints multiple lines of plain text in a report. This can be achieved by editing the 
white window as with the label described in B above, or by right clicking on the Memo 
block on your canvas and selecting ‘Lines’, you will then be presented with a small Word 
Processing type window in which you can type the text you require. This tool has limited 
Word Processing capabilities unlike the Rich Text tool – which is described in 'Rich Text' 
below. 

 

Rich Text: Prints formatted text. Right click on this block on your canvas and select ‘Edit’ 
to access the Rich Text Editor window and its word-processing features. 

 

System Variable: Displays common report information such as page number, page count, 
print date and time, and current date and time. When first chosen it defaults to ‘Date’ but 
clicking on the drop down box allows a number of other options to be chosen instead. 

 

Variable: Performs calculations. This tool is used together with the Calc tab and is used 
for advanced calculations, an explanation of which can be found in Chapter 5 

 

Image: Displays graphics such as bitmaps, GIFs, and JPEGs. This would be used where a 
company logo is required on a form. 

 

Shape: Displays various shapes, such as squares, rectangles, circles, and ellipses. It initially 
defaults to a Rectangle – use the Edit toolbar (see page 26) in the top left hand corner of 
the screen to select a different shape. 

 

Line: Displays a line. Use the edit toolbar to set the line orientation – top or bottom, left 
or right.  

 

BarCode: Renders text as a barcode. Use the Edit tool-bar (see page 26) to set the text to 
be encoded. Right-click and choose Configure from the popup to select industry standard 
bar code types. 

 

2d BarCode: Renders text as a 2d barcode. This is also known as a matrix code, a two-
dimensional way of representing information. It's similar to a linear barcode, but has 
more data representation capability. 

 

Chart: Displays TeeChart (see page 136) charts in the report. 

 

Checkbox: Displays a checkbox icon that can be set as checked or unchecked by right 
mouse click. 

 
HTML Text: Displays HTML content. Right click on this block on your canvas and select 
‘Edit’ to access the HTML Editor window. 

 

Total Variable: Used to perform totals for groups and reports. Configured by right 
clicking, choosing ‘Grand Total’ and then selecting from the drop down list what should 
be totalled. 
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Data Component Palette 

 
Data Component palette offers several components that are identical to ones in the standard palette, 
except for one thing: they are “data aware”, also known as “data bound”. 

Data aware components have the ability to read the value of a field from a database table at run-time, and 
then display that value in the report. This is different from the standard components, which display the 
content assigned when you lay out a report (design-time). You associate a data aware component with a 
given data pipeline and field by selecting the pipeline and field from drop-down lists in the edit toolbar (the 
two white boxes with drop down capabilities located in the top left of your screen). 

Icon Description 

 

DBText: Displays data from most types of database fields. Cannot handle images or Rich 
Text. 

 

DBMemo: Prints plain text from a memo field of a database table. It will automatically 
word-wrap the text, and can be set to stretch vertically down the page to accommodate 
larger text fields. 

 

DBRichText: Prints formatted text from a memo field. It will automatically word-wrap the 
text. 

 

DBCalc: Performs simple database calculations (Sum, Min, Max, Average, Count). Placing 
one of these on your report will result in a box containing “Sum(?)”.  To replace the ? with 
the database field to be manipulated, select the field from the drop down box of fields in 
the top left of your screen. To replace Sum with one of the other functions, right click on 
the box and select Calculations. 

 

DBImage: Prints graphics (Bitmaps, GIFs, JPEGs) that are stored in a database field. 

 

DBBarCode: Renders a database field as a barcode. Use the drop down box of database 
fields from the Edit toolbar (see page 26) to set the Database field to be encoded. Right-
click and access Configure to select from the list of industry standard bar code types. 

 

DB2dBarCode: Renders database field as a 2D barcode. Use the drop down box of 
database fields from the Edit toolbar (see page 26) to set the Database field to be 
encoded. A 2D barcode is also known as a matrix code, a two-dimensional way of 
representing information. It's similar to a linear barcode, but has more data 
representation capability. 

 

DBCheckbox: Displays a checkbox for a Boolean value in the database. Select the table 
and field from the drop down boxes. You can also set the BooleanFalse and BooleanTrue 
properties of the checkbox in the Properties sidebar. Boolean True and Boolean false 
represent the ‘field value to produce a check’ and ‘field value for an uncheck’. You could 
also replace the 1 and 0 in the illustration below with Y and N should your database field 
contain these or T and F. 
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DBChart: Displays a chart based on one or more data series from the defined data 
pipelines. Right-click and select Edit Chart to configure the type and properties of the 
chart you wish to display. 

Clarity provides the ability to paste components or sets of components between reports. This can be useful 
when copying layouts from one report into another.   

Be sure to check that the data aware components pick up the correct data field, and reassign them where 
necessary. Note that any Variable expressions or Calcs code will not be transferred across, so this needs to 
be entered manually.  

Nudge Toolbar 

 
The Nudge toolbar is useful when you want to move a component or selection of components (see page 
30) with extreme precision. Select a label on your report and then try clicking on each icon (as described in 
the table below) in turn. 

The arrow on each icon represents the direction the selected item will move. Selections will move one pixel 
each time you click. You can also move selected objects one pixel at a time by pressing CTRL+Arrow Key. 

Icon Description 

 

Nudge up: Moves all selected components up one pixel. 

 

Nudge down: Moves all selected components down one pixel. 

 

Nudge left: Moves all selected components one pixel to the left. 

 

Nudge right: Moves all selected components one pixel to the right. 

Size Toolbar 
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You can use the Size toolbar to set all of the components within a selection (see page 30) to a uniform 

height or width. The numbered items in the table reference to the diagram below.  Illustrates the 
original rectangles before the size transform has been applied.  

To make a selection select a component from the design canvas on the report and then while holding down 
the Shift key select a another component so that both have tiny grey circles at their corners.  Then click on 
each icon in turn, it's recommended viewing the selection topic (see page 30) for details on this. 

Icon Description 

 

Shrinks the WIDTH of all selected components to the width of the narrowest. 

 

Increases the WIDTH of all the selected components to the width of the widest. 

 

Shrinks the HEIGHT of all selected components to the height of the shortest. 

 

Increases the HEIGHT of all the selected components to the height of the tallest. 

 
Note: The selected components do not have to be the same shape, i.e. a this will work on a 
combination of ellipses, circles, squares, text, lines etc. 
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Draw Toolbar 

 
The Draw toolbar is used to set the colour and style used by shape, line, and region components. 

Icon Description 

 

Fill Colour - Sets the colour for a shape or region. Applies to shape components only. 

 

Line Colour - Sets the colour of the border for shapes and regions. Sets the colour for a 
line. 

 

Line Thickness - Determines the thickness of a line. Applies to line components only. 

 

Line Style - Sets the style of a line. 

 

Align or Space Toolbar 

 
The Align or Space toolbar is useful when two or more components need to be positioned uniformly. For 
example, it can align several components so that the tops are all in line or it can space components so that 
they have an equal amount of space between them.  

The first component selected (see page 30) determines the position to which the others will align.  

Note: The trick is to ensure that the thick black line on the icon represents the border that you want 
to have aligned. 

Alignment always occurs based on the first component you select when you are selecting multiple 
components 

Icon Description 

 

Align Left Edges - Aligns a group of components with the leftmost position of the 
component that was first selected. 

 

Align Horizontal Centres - Centres a group of components based on the horizontal centre 
of the first-selected component. 

 

Align Right Edges - Aligns a group of components with the rightmost position of the first-
selected component. 

 

Align Top Edges - Aligns a group of components with the topmost position of the first-
selected component. 

 

Align Vertical Centres - Aligns a group of components based on the vertical centre of the 
first-selected component. 

 

Align Bottom Edges - Aligns a group of components with the bottommost position of the 
first-selected component. 

 

Space Horizontally - Spaces a set of components based on the leftmost position of the 
first-selected component and the rightmost position of the last-selected component. 
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Space Vertically - Spaces a set of components based on the topmost position of the first 
component selected and the bottommost position of the last component selected. 

 

Centre Horizontally in Band - Centres a component horizontally within a band. 

 

Centre Vertically in Band - Centres a component vertically within a band. 

Advanced Component Palette 

The Advanced Component palette contains components that can help you tackle and control complex 
reporting layouts. 

Icon Description 

 

Region - Logically groups components together. To achieve this you need to place the 
region on the canvas first and then place the other components on top of it. This defaults 
to having a line around it but the choice of ‘No line’ can be selected from the Line Colour 
tool. When the region is moved, all components in it also move with it. When the region is 
made invisible, all components in it are also hidden. 

 

Sub Report - Handles multiple master details, creates side-by-side reporting effects, and 
hooks reports with different data sources together as one. This is discussed in detail 
under the Sub Reports topic which is a part of the Advanced Clarity Course. 

 

Page Break - Allows advanced control over pagination. 

 

Crosstab - Allows the user to generate a set of calculations that summarize grouped or 
aggregated data from database tables and provide a way of extracting a great amount of 
information from data. Crosstab reports display the calculations in a grid format similar to 
the following illustration. 
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The Report Tree 

 
The Report Tree can be used to view the components within each band of the report in a tree-like 
structure. Components selected in the Report Tree become the selection in the report layout. 

You can rename components by right clicking over the name, selecting Rename, and then typing in a new 
name. Make sure to press the ENTER key after renaming to ensure that the new name is assigned. 
Renaming objects is useful if you are planning to use them in calculations or formulae. This tool window is 
dock-able only on the left and right sides of the design workspace. When selected the properties of the 
component are also displayed and can be altered. 

1. Report tree - shows each object on the form in a tree structure. 

2. Properties list - shows advanced properties for the currently selected object. If the report itself is 
selected then it shows the report properties. 



MYOB EXO Clarity 

24 

The Data Tree 

The Data Tree can be used to create data-aware components within a band. Simply select a set of fields and 
drag the selection into the band. A set of corresponding data-aware components will be created. This tool 
window is floating, and dock-able only on the left and right sides of the design workspace. 

 
1. Data Tree - Shows all of the data pipelines in the data workspace, as well as three special data 

sources: plGlobalVars, plParams and plTemplate.  These are not discussedin any detail here. 

2. Field List - Shows the MYOB EXO Business database fields available. Individual fields can be dragged 
from here onto the report. 

Data Tab 
This view shows what data is available from the currently selected data pipeline. The screen shot above 
illustrates how the Data Tree looks when the Data tab is selected.  You can drag fields directly from here 
onto your report canvas to create a DBText component linked to the selected data field. 

Layout Tab 
The Layout tab allows you to control the format of the components created when you drag fields from the 
Data Tree into the layout. You can have it create just a Label, just a DBText or both for each field you drag 
from the Data tab. You can also specify the orientation of the label relative to the DBText, and the font size 
and style to use. 
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Standard Toolbar 

 
The Standard toolbar allows you to perform basic functions such as opening, saving, and printing reports, as 
well as cutting and pasting selections. 

Icon Description 

 

New Report - Creates a blank report. 

 

Open Report - Displays the Open dialog, allowing you to open an existing report. 

 

Save Report - Saves a report to file. 

 

Page Setup - Displays the Page Setup dialog, allowing you to set the paper size and 
configure the layout for the report. 

 

Print - Displays the Print dialog before sending the report to the printer. 

 

Print Preview - Displays the Preview tab. 

 

Cut - Places the currently selected components in the clipboard and removes them from 
the report canvas. 

 

Copy - Copies the currently selected components into the clipboard. 

 

Paste - Pastes the components in the clipboard into the report layout. 

Note: Clarity provides the ability to paste components or sets of components between reports. This 
can be useful when copying layouts from one report into another. Be sure to check that the data 
aware components pick up the correct data field, and reassign them where necessary. Note that any 
Variable expressions or Calcs code will not be transferred across, so this needs to be entered 
manually. 

Format Toolbar 

 
Use the Format toolbar to set the font and colours of text-based components. You can also control the 
layering of components with this toolbar. 

Icon Description 

 

Name - Shows the name of the font chosen for the selected component. 

 

Size - Shows the size of the font chosen for the selected component. 

 

Bold - Sets text to bold. 

 

Italic - Sets text to italic. 
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Underline - Underlines text 

 

Left Justify - Left justifies text. 

 

Centre - Centres text. 

 

Right Justify - Right justifies text, as would be usually used for numbers 

 

Fully Justify – Fully justifies paragraphs of text, usually used in memo fields. 

 

Font Colour - Sets the text colour. 

 

Highlight Colour - Sets the background colour. 

 

Anchor - New anchor property allows control to reposition itself when layout changes. 

 

Border - New border property for all controls. 

 

Bring to Front - Brings a component to the front of other components. Ideally a text 
label should be in front of all graphic elements. 

 

Send to Back - Sends a component to the back of the other components. You can use 
the Report Tree to see the exact layering of the components within the band. 

Note: When layering (placing objects on top of each other) the latest object placed is on the upper 
most layer. Therefore if inserting a shape, it needs to be sent to the back so that it does not hide 
labels in the report.  

Edit Toolbar 

The Edit toolbar is unique in that it changes based on the selected component. It consists of 2 boxes with 
drop down capabilities. It is used with the following components:  

• Data-aware components  
• Labels  
• Shapes  
• Lines  

Edit Toolbar with a Data-aware Component 

 
This configuration allows the data pipeline (1) and data field (2) for the component to be set. 

Edit Toolbar with a Label Component 

 
This configuration allows you to type the text for a Label 
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Edit Toolbar with a Shape Component 

 
The Edit toolbar allows you to choose from several shapes when a shape component is selected: 

1. Choose the shape tool from the standard components toolbar. 

2. Insert the shape in the canvas (see page 2) area of the designer.  

3. Choose the shape type from the Edit toolbar drop-down. 

4. For ease of identification, rename the shape to a descriptive term in the report tree (see page 23). 
This is optional. 

Edit Toolbar with a Line Component 

 
This configuration allows you to move the line to the top, bottom, left, or right within a line component. 

Report Menu 

The Report drop down menu includes a number of features that are not covered elsewhere. 

Title 
The Title band does not appear in the default Design canvas. It needs to be checked here to activate it. The 
Title band serves the same purpose as the Header band except that it only prints on the first page and not 
on subsequent pages. If both title and header are activated, the Title band appears above the header band. 
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Summary 
The Summary band always appears below the last line of information on the report. The two options are to 
print it directly below the last line of information or to print it just above the footer on the last page. 
(Summary to Bottom option on the Tools menu) Although on the canvas the footer appears above the 
Summary band, in reality when the report is printed, the footer is printed at the bottom of each page and is 
always the last thing printed. 

Header / Footer 
The header and footer appear at the top and bottom of each page respectively. These menu options allow 
you to show or hide the sections. 

Page Style 
This band, when activated, appears at the bottom of the canvas. Anything entered in this band appears 
‘behind’ the report, as would a watermark. Therefore, if you need lines to run the length of an invoice or a 
border around the page, you would add these to the Page Style band.  

Groups 
The Groups menu item allows you to set up groups in your report (see page 38). This grouping is similar in 
purpose to the Groups tab in the Data view when setting up a data pipeline, however this option is easier 
to implement and understand when creating basic reports. Remember that in order to group things here, 
they must be sorted by the same fields and in the same order in your data pipeline or the grouping will not 
make sense. 

Outline Settings 
The Outline Settings property, once enabled, is available only in the Preview tab of the Clarity designer (see 
page 3). It shows a tree view display of the various groups in the report and optionally the pages they 
appear on. Clicking the groups or the page numbers takes the user directly to the appropriate page. 
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Find Text Settings 
Another setting that is available only in the preview tab of the clarity designer, the Find Text Settings 
window provides the user with the ability to search for strings within the report. 

 
The user can specify whether the search will be case sensitive or whole word, whether the starting page for 
search would be the first page or the current one. The default find text string can also be specified. 

 

Portrait / Landscape 
This is a quick way of setting the orientation of the report on the page.  Another method is to go into the 
File > Page Setup menu item and change it on the Paper Size tab. 
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Pass Setting 
There are two options here – One Pass or Two Pass. This is an advanced setting that beginner Clarity users 
shouldn’t be too concerned with. Basic reports should run fine on either setting, although for large reports 
you may notice reports run more slowly when set to Two Pass. Without getting into too much detail here, 
Two Pass and this is as the name suggests – the computer goes through the data twice – doing all the 
calculations out on the first pass and then formatting and printing the report on the second pass. The one 
pass does it all in one go.  You may find that in complex reports this setting needs to be taken into account 
to ensure, for example, that variables are not calculated twice (when set to Two Pass), or that report totals 
are not calculated correctly before generating (if set to One Pass). 

Units  
A number of different units of measurement are available to select from. These apply to all reporting 
features (custom page size, position of labels etc.). 

Selecting Components 

There are numerous benefits to the correct selection of components in the design canvas. The overall 
benefit is time saving, reducing repetitive keystrokes and mouse manipulations. Other benefits are 
improved precision on the layout of the report, vital to a functional report. 

There is a combination of methods for selecting components in the design canvas. This may sound straight 
forward, however to effectively use the design tools available, it's important to understand these different 
methods of selecting components. 

 

Selecting Groups 
The first method is to select a group of components, to do this: 

Place the mouse cursor at the lower right of the group. 

Click and hold the mouse cursor so that the dotted rectangle encompasses and crosses all items 
required for this selection. 
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Release the mouse button and the selected items will be highlighted with grey grips. 

Selecting groups is useful when you need to: 

• Move a group of components around the canvas, after the selection, click on an item - hold the 
mouse button down and drag the selected group to a new location on the canvas. For precise 
movements of this selection, use the Nudge Toolbar (see page 19). 

• Align (see page 21) the selected object to a specific location on the canvas. Using this selection 
method is not recommended for this as there is no control on which is the first item selected. A 
combination selection method (see page 32) is recommended for this option. 

• Changing multiple attributes, such as font styles, line types and fills etc. Changing font size will work 
even though there are shape components combined in this selection. The shapes will be ignored 
and only the applicable attribute changes will be made to the relevant components in this 
selection. 

• Make these components a uniform size using the size toolbar (see page 19). Using this selection 
method is not recommended for this as there is no control on which is the first item selected. A 
combination selection method (see page 32) is recommended for this option. 

Note: Items can be selected across the bands (see page 2) using this method. See the illustration 
below: 

 
1. Select the components across the bands. 

2. De-select (see page 32) the rectangles. 

3. Align the selected items left. 

4. On preview, it is apparent that the selected items are precisely in line. 
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Individual Selections to Groups 
To select components individually, hold down the shift key when selecting components with a single left 

click. This is illustrated in  top. You can do the same things as a group selection, however selecting 
individually gives you the added control over which components are to be modified. 

Note: Selected items can be removed using the same method, i.e. you could select all components 
on the page Ctrl + A then remove the ones from the selection that aren't required by holding down 
shift and clicking them. 

Combination of Both Selection Methods 
You can either select individual items as above and while holding down the shift key, use the group 
selection method and vice versa. This method is recommended when using the Align (see page 21) and Size 
(see page 19) tools. These tools use the first object selected as a reference object and shift + selecting the 
first object, followed by shift group selection, gives you control as to which is the first object selected.  

Selecting and Individual Component 

When a single component is selected, the grips change appearance,  top. This indicates that you can 
manipulate the component using these grips, scale, width and height. The cursor will change to a double 
arrowed icon when on a grip, click, hold and drag to transform the selected component. 

Creating your First Report 
This simple overview provides an introduction to the MYOB EXO Clarity Report Designer basics, the Query 
Designer, and the process of building reports. The purpose of this overview is to show you what it takes to 
build a report and to get an overall idea of the concepts. If you feel a little lost, don't worry. The meaning 
behind the actions will become clearer as you progress through the topics. 

Follow the steps given in this section to create a sample report contain the following items: 

• A list of stock items 
• A selling price for each item 
• A Latest cost for each item 
• A GP% for each item 

Plan the Data Source 

Before starting a report, take the time to plan the data source. 

Which fields are required to create this report? 

Item  Fields Required 

A list of stock items Stock_Item.Stockcode, Stock_Item.Description 

A selling price for 
each item 

Stock_Item.Sellprice1 

A latest cost for each 
item 

Stock_Item.Latestcost 

A GP% for each item No further fields required (GP% can be calculated by (Sellprice1-
Latestcost) / Sellprice1 * 100) 

Which tables are needed to supply these fields? 

All of the above fields can be found in one table: Stock_Items. 
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Start Clarity 

It will be helpful for you to become familiar with the following steps, because you will repeat this process to 
begin any report that you are writing from scratch (except FMT conversions). 

Launch the Clarity Report Designer from the MYOB EXO Business Utilities menu. 

1. Click on File > New Report, or the blank document icon on the main toolbar. 

2. Click on the Data tab (see page 4). 

3. Select File > New in order to access the New Items dialog. 

4. Double-click on the Query Designer icon. The Query Designer will come up with a list of available 
tables. 

In the Query Designer 

1. Choose the Stock_Items table by double-clicking on it. This table should now appear in the list of 
Selected Tables.  

2. We have finished selecting tables for now, so select the Fields tab (see page 8). 

3. Note that all fields are preceded by the table name and a dot. 

4. Select the fields as listed below for this example by double clicking on them.  

 
5. Move to the Calculations tab (see page 10). 

6. Double-click on the Latestcost field. 

7. From the drop-down list box in the Function column, Change from Sum to Expression. 

8. Enter the following calculation into the Expression edit box:  

(Sellprice1 – LatestCost)/Sellprice1*100 

9. Change the name of the Field Alias to GP%. 
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10. Move to the search tab (see page 11) and double click on Sellprice 1. In the box below specify that 
Sellprice1 <> 0.  This is because there may be some zero selling price1’s in the database and the 
computer is unable to divide by 0. 

11. Move to the sort tab and select the Stock Code field. 

12. Move to the SQL tab (see page 13) and change the name of the data source to Stock_Listing. 

 
13. Click OK 

You've officially completed your first query via the Query Designer. You'll notice a new window in 
the upper left-hand corner of the data tab workspace. This is a data view of the query, and 
represents the data that will be selected from the database each time the report is generated.   

14. Preview the data produced by this data source by using the page and magnifying glass icon: 

 
We will now add another query to the same report and you will see that this additional query need not in 
fact be joined to our first query at all. 

1. Click on File > New, and choose query designer. 

2. Choose the General_Info table by double clicking on it. Note that you can type ‘G’ and the cursor 
will jump to General_Info in the list. General_Info contains the registered MYOB EXO Business users 
company information and tax registration details required on many reports. 

3. Move to the Fields tab and select the Username only. Click OK. 

4. You are back in the Data tab and General_Info appears as a dataview on your Query tab. Now let’s 
begin laying out the report: 

5. Click the Design tab. 

6. Clarity will need to know which query on the Data view tab represents the Primary detail section of 
your report. This means it wants to know the main table on which you will be building the report. 
This is essential. In our case it is the first query we created via the wizard, called Stock_Listing. 
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Note: If you select the wrong table don’t panic – click on the Report menu and choose Data… 
The above box will appear once again and you can change the table. 

7. Select File > Save As… and save your report as MyReport.CLR. 

Design Workspace 

The Design workspace (see page 2) (also known as the report canvas) is the environment in which you will 
build your report layout. The workspace is divided up into “sections” or “bands”, with each band’s title and 
height-adjustment bar immediately below. 

• The header band (the white space above the word 'Header') will appear at the top of each page of 
the report. 

• The detail band will be the body of the report. 
• The footer band will appear at the bottom of each page of the report.  

There is a further band that can be chosen from the Reports menu called Summary and this prints either 
below the last line of data on the final page or just above the footer on the final page depending whether 
the  ‘Summary to Bottom’ option has been chosen from the Tools menu. It is important to note that even 
though the summary band appears below the footer band on the Design tab, it will always appear above 
the footer band on the report. When a report has a footer, it is always the last thing on the page. 

To begin the report: 

 
1. Locate the label icon on the Standard Component Palette (see page 15) toolbar and click on it. 

2. Click in the white space of the header band (see page 2) to create a label. 

3. Create two more labels in the header band using the same principles. Don't concern yourself with 
alignment. 

4. Select 'Label1'. 

5. Locate the Edit toolbar (see page 26) (below the label component icon on the toolbar). It should 
contain the text 'Label1' in a white box, which is the caption of the currently selected label. 

6. Highlight the text in the Edit toolbar and type ‘Product’. 

7. Select Label2 and type ‘Description’ into the edit toolbar. 

8. Select Label3 and type ‘Selling Price’ into the edit toolbar. 
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9. Continue placing labels for Latest Cost and GP% across the band. 

10. Press CTRL + S to save your work. 

Now add some data fields to the report: 

1. Select the Product label. 

2. Hold down the SHIFT key and then click on the other labels. All the labels should now be selected 
(see page 30). You can tell that they are selected by the small grey boxes at the corners of each 
label. These boxes are called selection handles. 

3. Click the bold icon. All the label captions should turn bold. 

4. Click the DBText icon on the toolbar. 

 
5. Place a DBText component in the detail band (do this by clicking in the Detail band). 

6. Change the text from bold to regular by clicking on the bold icon. 

7. Place four more DBText components in the detail band. 

8. Select DBText1.  Notice that there are two drop-down list boxes in the Edit toolbar (see page 26). 
The drop-down list box on the left contains all the report a sources (Stock_Listing, General_Info and 
the three special data sources). The drop-down on the right contains the fields. 

9. Select Stock_Listing from the left drop-down list and select 'Stockcode' from the right drop-down 
list box.  

10. Continue selecting fields ‘Description’, ‘Sellprice1’, ‘LatestCost’ & ‘GP%’ in turn for DBText 
components 2-5. 

Things are probably looking a bit scattered - let’s tidy it up a bit.  

1. Launch the Align or Space (see page 21) toolbar by selecting View > Toolbars and clicking on Align 
or Space. (It may already be selected.) 

2. The toolbar should appear under the drop-down list boxes. 

 
3. Right-click on the ‘Product’ label (in the header band) and select Position. 

4. Set the Left to 5 and the Top to 5  

5. Click the ‘GP%’ label and move it almost to the right hand margin of the report. 

Now to align the labels: 

1. Select the Product label again, then hold down the SHIFT key and click on all of the labels remaining 
labels in the Header section. 

2. Click the Space Horizontally icon.   The labels should now be spaced evenly across the report. 
  (You can move them about manually later so that the fields that require more space on the report 
(such as description) will display nicely). 

3. Click the Align Top icon.  The labels should all align with the first label you selected.  
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4. De-select all the labels by clicking on an empty space on the canvas.  Select the ‘Product’ label again 
and then hold down SHIFT and select DBText1 (containing the StockCode field) and click the Align 
Left icon.  Repeat this step for the other labels and corresponding DBTexts but choose the Align 
Right icon for the numeric fields.  (Ensure that the numeric components and their labels are right 
justified also). 

5. Align the tops of all of the DBText components, as we did in step 3 for the labels. 

6. Press CTRL + S to save your work. 

Preview Window 

The Preview window in the Report Designer environment works the same way as the preview capability in 
most other Windows applications. It shows you what your report will look when it is printed. 

1. Click on the Preview tab (see page 3) and look at your report. Make sure that the columns are 
nicely spaced with plenty of room for long names.  

2. Everything should look good except for the rows, which are double- or triple-spaced. Double 
spacing takes up too much room and will waste paper when the report is printed.  Also you may 
wish to alter the number formats. 

Note: You cannot edit in the preview window. 

Tidying Up 

Even an advanced report writer will usually find several things that can be improved when previewing a 
new report. Let's fix the spacing to begin with. 

1. Return to the design workspace by clicking on the Design tab (see page 2). 

2. Press the left mouse button and draw a square around the fields in the details band of your report. 
The fields should all have grey dots (“handles”) at each corner. This indicates that it is part of a 
selection of multiple items (see page 30).  

3. Move one of the fields and notice how all of the fields move in unison, remaining in their relative 
positions to the field you are dragging. Move the fields to the top of the Details band.  

  

4. Place your cursor over the bar labelled Detail. Your cursor will change to an up/down arrow, 
indicating that you can drag the section divider up and down. (See below). 

  

5. Drag the divider (grey band) up until it meets the bottom of the components in the detail band. 
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6. To change the formatting of the number fields, right-click on the DBText component and select 
display format option.  Choose the format you require and click OK. 

7. Preview the report (see page 3).  

8. If any of the fields are truncating their data then right click and select the Autosize option. 

9. You might wish to put the MYOB EXO Business user’s company name on the top of this report. See 
if you can do this based upon what you’ve just learned. 

10. Close the Report Designer window by clicking the button at the upper right corner of the window. 

11. A dialog box asking you to save changes will appear. Click Yes. 

Congratulations! You've built your first MYOB EXO Clarity report! 

Grouping Data in a Report 

Groups 

Groups are added to a report so that summary information can be extracted from specified subsets of data. 
Grouping must be performed on discrete data fields; in other words, the data fields you group by must be 
able to be separated into distinct, identical groups. An example of a field that cannot easily be grouped is a 
“datetime” field like Transdate. This is because a datetime value can be any date or any time (down to 
fractions of a second). An example of a field that can be grouped is Accno – in other words, all records 
relating the same account will have the same Accno. 

Groups are represented in the report layout by a matched pair of bands: the group header and group 
footer. The group header prints when the group begins and the group footer prints immediately after the 
last detail band of the group. This process repeats itself until all groups have been processed. 

You are able to group data in a report by more than one field but it is imperative that the fields that you 
group your data by are also fields that you sort by and in the same order or your report will not make 
sense. Once the sort fields are properly set for the groups, extra sort fields can be added. This may be 
required, for example, to sort by the DUEDATE field for debtor invoices which have been grouped by 
branch then by debtor. In this case, your sort fields might be (in this order): DR_TRANS.BRANCHNO, 
DR_ACCS.ACCNO, DR_TRANS.DUEDATE. 

  



Clarity Report Designer 

39 

A Simple Grouping Example 

To view the invoices generated by a business, organized (grouped) by each Debtor: 

1. Use the Query Designer to create a data view consisting of required fields from the DR_TRANS 
table and sort the data by ACCNO: 

 
2. Close the Query Designer, then select Groups from the Report menu. Create a group based on the 

ACCNO field as shown below, then click OK. 
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The following design layout is produced.  Compare the numbers on the screenshot below to the 
report preview to get an idea of how the report groups are generated. 

 
3. In the Group Header section, place the repeating data for each group, i.e. the account data 

(because the ACCNO is the same for each item in the group).   

4. In the Group Footer, place the Summary data for each group, i.e. a dbCalc component displaying 
sum(Dr_Trans.amount).   

5. In the Detail section, place the invoice data (invno, amount etc…). 

6. Your report should look something like this (perhaps with different fields).  Compare the design 
view and preview below. 
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Runtime Parameters 

Parameters Editor 

To view the Parameters Editor, select Tools > Runtime Parameters. The Parameters Editor window is 
displayed. A description of each field on the window is shown below. 

 

Field Description 

Parameter Name This is the name of the parameter that will be used when the parameter 
value is accessed in code on the Calc tab. 

Control Number This determines the order of the components when they show on the 
parameter dialogue box. 0 is first, 1 is second, and so on. 

Control Type The type of control that will appear on the Clarity Report Launcher (text 
box, combo box, etc). 

Caption The caption that will appear alongside the control on the Clarity Report 
Launcher.  The caption is important because it will describe to the user 
which field the selection criteria will control. See item 6 in the example 
below. 

Table Alias The name of the data pipeline that the selection criteria affect. 

Key Field The field within the data pipeline that is filtered by the selection criteria. 

Operator The search operator that is applied to the key field, e.g. equal / greater than 
/ less than. 
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Default SQL for 
Key Field 

Only used with Listbox, Combobox, Checkbox, Textbox and OrderBy 
components.  The value that is entered into this box determines what is 
selected by default in the Listbox / Combobox when the Clarity Report 
parameter window pops up. 
For OrderBy fields, this is a comma-separated list of fields that you can 
select to order your data by (the labels on this window change to reflect 
this when you select an OrderBy type parameter). 

Source SQL Only used with Listbox, Combobox and OrderBy components. The SQL that 
will retrieve the values to be displayed in the Listbox / Combobox when the 
Clarity Report Launcher pops up. The name of the field for your “Key Field” 
must match one of the names of the fields in your source SQL statement. If 
there’s a difference (e.g. your Key Field is HDR_SEQNO and your combo has 
the field SEQNO), change “SEQNO” to “SEQNO AS HDR_SEQNO”. This is 
called aliasing a field and allows Clarity to match that field to the Key Field. 
For OrderBy parameters, this determines the default OrderBy field. 

Display Fields The fields that are highlighted in this box are the fields that will be 
displayed in the Listbox / Combobox when the Clarity Report Launcher pops 
up. To enter values into this box, double click on the SQL statement in the 
Source SQL box.  If it is a valid SQL statement, the list will automatically 
populate. The key field must be included in this list to be able to save the 
parameter. Of the selected fields, you can determine which ones will 
actually show by CTRL-clicking to select and de-select fields. 

Enabled Whether or not the component is enabled by default. Enabling / disabling 
can also be achieved at runtime by checking or un-checking the checkbox 
displayed alongside the component. 

Control Types 

The control types listed here are derived from the Control Type drop-down in the Parameters Editor 
window (see page 42). 
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Combo Box 

 
This parameter would select all periods where the STOCK_ITEMS.STOCKGROUP field is greater than or 
equal to the stock group selected by the user in the “From Secondary Stock Group” combo box. 

Notice that the default SQL uses “select min(groupno) from stock_groups”, which gives us the first stock 
group as a default. Groupname and Groupno are the fields that are displayed in the combo box. 
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List Box 

 
This parameter would select all records from DR_TRANS where ACCNO equals any of the accounts that the 
user has selected in the list box. Notice the extra field “Visible lines”, which tells Clarity how many lines high 
you would like the list box to be. 
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Check Box 

 
This parameter would pass a true value through to the report if the user checks the check box. Notice how 
this parameter is not tied to any data fields, so it does not affect the filtering. Instead, this field is intended 
for use within Calc code (in this case it would be used to determine whether or not the detail is visible). 


